Chủ đề

(Không gian mạng) - Một lỗ hổng nguy hiểm đã được phát hiện trong nhân Linux từ năm 2009, ảnh hưởng đến một số lượng lớn các phiên bản Linux, bao gồm Red Hat, Debian, Fedora, OpenSUSE và Ubuntu.

Lỗ hổng tồn tại trong suốt hơn 7 năm vừa phát hiện đã được vá /// Ảnh chụp màn hình

Lỗ hổng tồn tại trong suốt hơn 7 năm vừa phát hiện đã được váẢnh chụp màn hình

Theo hãng bảo mật Trend Micro, lỗ hổng mới nhất tồn tại trong nhân Linux suốt hơn 7 năm qua cho phép người không có đặc quyền trên thiết bị ảnh hưởng vẫn có thể chiếm quyền root hệ thống hoặc gây ra sự cố từ chối dịch vụ, khiến sập hệ thống.

Cụ thể, các nhà nghiên cứu đã phát hiện ra một vấn đề trong trình điều khiển N_HLDC trong nhân Linux, chịu trách nhiệm xử lý dữ liệu High-Level Data Link Control (HDLC), dẫn đến lỗ hổng double-free.

“Double-free” là một trong những lỗ hổng bộ nhớ phổ biến nhất, nơi hàm free() được gọi tới hai lần cho cùng một địa chỉ bộ nhớ, có thể dẫn đến lỗi tràn bộ đệm. Một kẻ tấn công có thể tận dụng lỗ hổng này để bơm và thực thi mã tùy ý.

Lỗ hổng mới phát hiện ảnh hưởng đến hầu hết các bản phân phối Linux phổ biến, bao gồm Red Hat Enterprise Linux 6, 7; Fedora; SUSE; Debian; và Ubuntu.

Theo hãng bảo mật Trend Micro, lỗ hổng này xuất hiện vào tháng 6.2009, do đó nhiều máy chủ và thiết bị doanh nghiệp vận hành trên nền tảng Linux đã phải đối diện với lỗ hổng trong thời gian dài.

Các chuyên gia bảo mật cho biết, hiện tại lỗ hổng đã được vá trong nhân Linux, và bản cập nhật bảo mật cùng các chi tiết lỗ hổng đã được công bố vào ngày 7.3. Vì vậy, người dùng được khuyến khích cài đặt bản cập nhật bảo mật sớm nhất càng sớm càng tốt.

(Theo Thanh Niên)

Bài viết, video, hình ảnh đóng góp cho chuyên mục vui lòng gửi về banbientap@nguyentandung.org
Thích và chia sẻ bài này trên